Error trying to install jpl library. jpl.dll: Can't find dependent libraries

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error trying to install jpl library. jpl.dll: Can't find dependent libraries

Kamil
This post has NOT been accepted by the mailing list yet.
I have a problem installing jpl library. I installed the latest swipl version (but I tried also unstable versions before):  

    SWI-Prolog 7.2.3 for Windows 7/8/10 64-bit edition

Then I added dependent paths to environment variables:

    Variable: SWI_HOME_DIR
    Value: C:\Program Files\swipl

Then I added, to `Path` these values:

    %SWI_HOME_DIR%\lib
    %SWI_HOME_DIR%\bin

I also added the VM argument like this:

    -Djava.library.path="C:\Program Files\swipl\bin"

to make sure that Eclipse sees this folder.  

After that I still get the error:

Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: C:\Program Files\swipl\bin\jpl.dll: Can't find dependent libraries
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1855)
    at java.lang.Runtime.loadLibrary0(Runtime.java:870)
    at java.lang.System.loadLibrary(System.java:1122)
    at org.jpl7.JPL.loadNativeLibrary(JPL.java:79)
    at org.jpl7.fli.Prolog.<clinit>(Prolog.java:41)
    at org.jpl7.Query.open(Query.java:260)
    at org.jpl7.Util.textToTerm(Util.java:102)
    at org.jpl7.Query.Query1(Query.java:129)
    at org.jpl7.Query.<init>(Query.java:120)

I'm 100% sure, that Eclipse sees that jpl.dll file.

I know that this thread is probably duplicate of either of these:
http://swi-prolog.996271.n3.nabble.com/jpl-dll-Can-t-find-dependent-libraries-td11513.html
http://swi-prolog.996271.n3.nabble.com/SWI-prolog-java-installation-error-td12458.html

but none of the solutions posted there, helped me.

I also find out that when I'm trying to run one of the examples, I get this error:

ERROR: c:/program files/swipl/library/jpl.pl:4174:
exists_file/1: Domain error: `file_name' expected, found `'C:\\Users\\Kamil\\AppData\\Local\\Microsoft\\Windowst\000\e\000\/jvm.dll'' (file name contains a 0-code)
Loading...